Author Topic: Old pictures of the 1969 Z/28 I owned in the late '70's  (Read 20102 times)

Mike S

  • Hero Member
  • *****
  • Posts: 1271
    • View Profile
Re: Old pictures of the 1969 Z/28 I owned in the late '70's
« Reply #105 on: February 20, 2013, 01:30:53 PM »
George,

  Now that picture of you car sure brings back memories. I had the same car in the same color including rear spoiler I purchased in 1975.
I sold in the mid-80's when the babies arrived and bought a K-car to become a family man (meaning I couldn't afford the gas and needed a bigger car to lug around cribs and baby seats)  :D By that time I had the two BB's I still have now but I sure miss driving the '71 daily with my wife (then girl friend).

Mike
67 LOS SS/RS L35 Hardtop - Original w/UOIT
67 NOR SS/RS L35 Convertible - Restored

NoYenko

  • Member
  • ***
  • Posts: 329
    • View Profile
Re: Old pictures of the 1969 Z/28 I owned in the late '70's
« Reply #106 on: February 21, 2013, 01:19:39 AM »
Mike, I laughed when I read your comment because my girl friend & I used to send a couple hours washing and polishing the car on a Friday night date. When I would take her home her mother would ask what we did and give me a stern look. She has stuck with me for 37 years. The 71 Camaros must be lucky. George

rat pack

  • CRG Member
  • *****
  • Posts: 222
    • View Profile
Re: Old pictures of the 1969 Z/28 I owned in the late '70's
« Reply #107 on: February 22, 2013, 02:57:10 PM »
Pace car....needed work!

I don't know how I missed this thread originally......  Is this the car you have now? I inspected a pace car a few years ago that could be a twin to this one. Very similar crash damage, and still sporting the Cragar type mag wheels. It looked like the Duke boys had played with it. Can't remember if it was an automatic or 4-speed, but had lots of options on it.......................RatPack........................
Just keep livin......L I V I N .............

69glacierblue

  • Member
  • ***
  • Posts: 50
    • View Profile
Re: Old pictures of the 1969 Z/28 I owned in the late '70's
« Reply #108 on: February 23, 2013, 02:23:06 AM »
Sorry it's Gen 2 but I didn't get my '69 till 2006!  My first Camaro, '70 Z28, 4-sp., motor stock except Nitrous, 1-off glassed-in back spoiler.  Yes it's posi- just a windy day. Pics from '78, owned it '77-'79, almost died the day I sold it but needed the money for college.
Dennis
'69 SS350 Vert (X55) 4-sp.
'10 2SSRS RJT M6

firstgenaddict

  • Hero Member
  • *****
  • Posts: 1402
    • View Profile
    • Groome Family Automobiles
Re: Old pictures of the 1969 Z/28 I owned in the late '70's
« Reply #109 on: February 24, 2013, 04:04:24 PM »
Sorry it's Gen 2 but I didn't get my '69 till 2006!  My first Camaro, '70 Z28, 4-sp., motor stock except Nitrous, 1-off glassed-in back spoiler.  Yes it's posi- just a windy day. Pics from '78, owned it '77-'79, almost died the day I sold it but needed the money for college.
Damn that is one Bad A$$ street machine... a bundle of snakes side pipes and it would be set right!
James
Collectin' Camaro's since "Only Rednecks drove them"
 
Check out the Black 69 RS/Z28 45k mile Survivor and the Lemans Blue 69 Z 10D frame off...
https://plus.google.com/photos/112392262205377424364/albums?banner=pwa

69Z28freak

  • Member
  • ***
  • Posts: 363
    • View Profile
Re: Old pictures of the 1969 Z/28 I owned in the late '70's
« Reply #110 on: March 04, 2013, 03:10:08 AM »
Sorry it's Gen 2 but I didn't get my '69 till 2006!  My first Camaro, '70 Z28, 4-sp., motor stock except Nitrous, 1-off glassed-in back spoiler.  Yes it's posi- just a windy day. Pics from '78, owned it '77-'79, almost died the day I sold it but needed the money for college.

Nice car. I had a '71 Z28, with the entire drive train from a totalled '70 Z28 in 1979, all stock. My first car as well. Brings back great memories.
Mike 1969 Grandma Camaro