Author Topic: Correct Centre Link finish  (Read 3132 times)

sixt9x33rs

  • Hero Member
  • *****
  • Posts: 858
    • View Profile
Re: Correct Centre Link finish
« Reply #15 on: June 12, 2013, 02:53:43 AM »
I have great pictures of my 69 Z suspension as I was pulling it out of evap o rust. All the original factory dab marks starting appearing as the surface rust was washing away. It was very cool. The problem is the the picture sizes are large to post on here. I will be happy to email to anyone interested.
'69 RS Z/28 Olympic Gold, 711
Flat hood no spoiler, black top, endura, 4:10
POP 39,000
69 X77 Z/28 69 711 Original Paint Unrestored
'69 X66 Convertible Cortez Silver 712 black top Endura, auto, bumper guards, am/fm rear speaker 44k miles

Hans L

  • Member
  • ***
  • Posts: 144
    • View Profile
Re: Correct Centre Link finish
« Reply #16 on: June 13, 2013, 07:30:25 PM »
For reference, here's some more pics consistent with what others have posted regarding center link and idler arm finishes - after I cleaned them up but before installed on the car.  Mostly just degreased the parts.  Idler arm part that mounts to frame has blackish finish and center link was grayish and maybe with hints of blue:

No paint on the parts....only applied Boeshield.










http://www.littooy.com/hans/
'69 Camaro RS Z/28 Van Nuys Built

69Z28freak

  • Member
  • ***
  • Posts: 363
    • View Profile
Re: Correct Centre Link finish
« Reply #17 on: June 18, 2013, 12:20:12 AM »
For reference, here's some more pics consistent with what others have posted regarding center link and idler arm finishes - after I cleaned them up but before installed on the car.  Mostly just degreased the parts.  Idler arm part that mounts to frame has blackish finish and center link was grayish and maybe with hints of blue:

No paint on the parts....only applied Boeshield.


Looks great Hans. Nice to see the Cortez Silver shell in the background.
Mike 1969 Grandma Camaro

Hans L

  • Member
  • ***
  • Posts: 144
    • View Profile
Re: Correct Centre Link finish
« Reply #18 on: June 18, 2013, 03:56:33 PM »
Thanks Mike!  Can't wait to get it done.    Restoring all the subcomponents seems to take forever.  One of these days, I'll start a build thread on Team Camaro.  I've been following yours - some good info I've picked up from your thread there.