CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
November 21, 2014, 07:15:08 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
106450 Posts in 12410 Topics by 4785 Members
Latest Member: Bolaro 67 SS350
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  General Discussion
| | |-+  67 Powerglide partial VIN.
« previous next »
Pages: [1] Print
Author Topic: 67 Powerglide partial VIN.  (Read 592 times)
MyRed67
Hero Member
*****
Posts: 715


SZZLN 67

michael-l.campbell@hotmail.com
View Profile
« on: August 29, 2012, 10:18:36 PM »

  Did all '67 Powerglide Transmissions get a partial VIN. stamp, or just those used behind Hi Perf. engines?
Logged

1967 Camaro  LOS  11A
Original Engine   Z - Tribute
Mike C.    NW - Illinois
tmodel66
Hero Member
*****
Posts: 1212


View Profile Email
« Reply #1 on: August 30, 2012, 08:41:17 AM »

I think you are right on stamping only Hi-Po parts prior to '68. I'm no pro on all this but to my understanding mandatory on all parts VIN started stamping in '68
Logged

Daniel  
'69 SS 350/4 speed  Fathom Green--POP
Petes L48
Member
***
Posts: 311



View Profile
« Reply #2 on: August 30, 2012, 09:11:01 AM »

Most likely just those that had the block stamped, since the same gang holder was used on the trans.  Exceptions may have been found, the experts will weigh in on those.  I can't find it now but thought I once read that on early 67 LOS cars, trans stamping was intermittent, so for example you might find an L48 w/o the stamp.  The POP would show the transmission assembly plant code, regardless of engine size. See the POP section, also the very end of the Drivetrain sections on this site  http://www.camaros.org/drivetrain.shtml
  
Logged
67 RS Ragtop
Member
***
Posts: 82


View Profile Email
« Reply #3 on: August 30, 2012, 10:27:07 AM »

My early '67 with L-30, powerglide has no vin stamp at engine or trans (LOS car), was advised by Kurt that this was a "normal" condition for early cars.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.072 seconds with 17 queries.