CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
September 23, 2014, 09:29:45 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
104711 Posts in 12247 Topics by 4719 Members
Latest Member: Baconcks
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Maintenance
| | |-+  Speedo assembly and my dripping transmission. help
« previous next »
Pages: [1] Print
Author Topic: Speedo assembly and my dripping transmission. help  (Read 1668 times)
nlpirr
Member
***
Posts: 52


View Profile
« on: April 18, 2006, 01:03:35 PM »

I posted this earlier and tied it to my restoration of my dash. I'm hoping to get a few tips on the " maintenance" forum.

 I disengaged the speedometer cable from the speedometer and now my assembly drips transmission oil from the side of the tranny where it attaches to? even after I reconnected the cable back into the speedometer?

Anyone have any tips as to what I need to do to stop the bleeding would be very helpful. I have yet to even touch the transmission so I'm a real newbie at this.

Nick p.


 
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.072 seconds with 17 queries.