Author Topic: 69 RS vacuum tank relay switch  (Read 1557 times)

wolfe1

  • Guest
69 RS vacuum tank relay switch
« on: September 09, 2007, 02:23:44 PM »
I posted this over at Team Camaro and didn't get any feed back, so I was hoping someone here could help me out. I've got an original GM vacuum switch that leaks out the bottom. The diaphram is fine, I believe it's the cup seals in the valve body. Has anyone ever rebuilt these or have pictures of the internal parts? If so, how did you get it apart and where did you find the seals. I don't want to cut the steel ring around the diaphram. I removed the crimped washer off the bottom of the shaft, but still can't get the seals out the bottom. Thanks, John

9T4Z

  • Member
  • ***
  • Posts: 239
    • View Profile
    • Gary's Camaro
Re: 69 RS vacuum tank relay switch
« Reply #1 on: September 13, 2007, 03:06:29 AM »
I saw your post on TC as well.... no reply because I don't know of anyone rebuilding the unit.... I for one would be interested in finding out also as mine is leaking as well.  I am considering purchasing a repro unit... they are about $70 and available from various suppliers...

if you do take it apart post some pics.. maybe you can be help a few people out if you solve it...

good luck
Gary 9T4Z

94Z rag blower 491 rwhp (now 505!)
69 Pace Car, 70RS,91Z,91RS

wolfe1

  • Guest
Re: 69 RS vacuum tank relay switch
« Reply #2 on: September 13, 2007, 03:11:44 PM »
Thanks for the reply Gary. I figured that was the case. For some reason I've got this thing about preserving the original parts. I guess it's a disease.

I did end up cutting it apart. I took a dremel tool with a thin cut off wheel a cut a slot through the metal band holding the diaphram together. The band is soft enough that you can spead it open without breaking it. Once apart, I realized why you can't get the seals out the bottom. There are 2 cup type seals molded to either end of a plastics spacer shaped similar to a streached hour glass. The spacer appears to have been molded over a brass core that slips over the center shaft that is visible from the bootom of the valve. How it's fixed to the rod I don't know but it doesn't come off. The rod is soldered to the center of the diaphram plate.

What I ended up doing was cutting a groove with the Dremel tool around the base of eack cup seal to mount an O-ring that I got at Ace Hardware.  I reassembled everything and put the band back around the housing. To hold it together, I drilled 2 tiny holes across from each other on either side of the cut on the bottom side of the band. Then I used super fine wire to tie them together. I place the spit on the down side so it's not as noticable. The spit could be covered with filler and the band painted I suppose.

Anyway, the leaks are gone and it seems to work fine. Hope this helps. If I end up taking it apart again I'll get some pics.