Author Topic: "Flickering" speedo needle  (Read 1245 times)

Fred Mertz

  • Member
  • ***
  • Posts: 51
    • View Profile
"Flickering" speedo needle
« on: July 11, 2016, 04:57:03 AM »
I've been having this problem for quite some time.  I have replaced the cable and the driven gear.  I also pulled  the core out of the new cable and lubed it with white lithium grease.

It there a way to lube the speedo itself?  What would I used if it can be lubed?

 It's a '69 Camaro.  Thanks, Dave

The speedo is an OER repo unit.

L78 steve

  • Hero Member
  • *****
  • Posts: 780
    • View Profile
Re: "Flickering" speedo needle
« Reply #1 on: July 13, 2016, 04:33:02 PM »
If the cable is new run it around for a while and it should settle down.
69 Z/28 Dover White. SOLD
67 SS/RS Mt. Green 1W,2LGSR,3SL,4K,5BY,07C. SOLD
70 Nova L78 Blk. Cherry,Sandalwood,M21,02B

ko-lek-tor

  • Hero Member
  • *****
  • Posts: 1465
  • someday I'll get one finished
    • View Profile
Re: "Flickering" speedo needle
« Reply #2 on: July 13, 2016, 05:37:50 PM »
For some reason I am thinking graphite oil is what cables and speedos use
James to strangers, Bentley to friends
1969 SS/RS 396 coupe Hugger Orange X22 712 bought in 79
1969 SS 350 coupe LeMans Blue 713 bought in 79
1969 307 4spd. coupe Daytona Yellow 711 bought in 85

Stingr69

  • Hero Member
  • *****
  • Posts: 554
    • View Profile
Re: "Flickering" speedo needle
« Reply #3 on: July 14, 2016, 12:45:39 PM »
I remember the recommended alternate lube was a mix of lithium white grease and ATF.

Mike S

  • Hero Member
  • *****
  • Posts: 1912
    • View Profile
Re: "Flickering" speedo needle
« Reply #4 on: July 14, 2016, 01:00:30 PM »
 Can you put one end of the cable in a drill and spin it with the cable straight to see if it flickers then? That would help determine if it's due to the cable routing under the body and somehow binding inside the sheathing due to internal wear.

Mike
67 LOS SS/RS L35 Hardtop - Original w/UOIT
67 NOR SS/RS L35 Convertible - Under restoration

Fred Mertz

  • Member
  • ***
  • Posts: 51
    • View Profile
Re: "Flickering" speedo needle
« Reply #5 on: July 14, 2016, 11:12:27 PM »
The cable core spins freely in the sheath. I had the core out right after I installed new cable when still "flickered" I lubed the core with white lithium grease from a tube (not spray).  The driven gear is also new.  It installed with no issues.  The cable is routed and secured at the factory locations.  I have ordered a used original speedo to try next.  It won't show up till this weekend.  I will follow up.  ???

cook_dw

  • Hero Member
  • *****
  • Posts: 2434
    • View Profile
Re: "Flickering" speedo needle
« Reply #6 on: July 15, 2016, 04:37:26 PM »
Do as Mike suggested and get under the car with a cordless drill and have someone look at the speedo and see if it flickers then.  Save you from having to pull the dash just to try another speedo..
Darrell Cook

Contact me if you have a 68 L78/L89 Camaro to add it to my database.

Fred Mertz

  • Member
  • ***
  • Posts: 51
    • View Profile
Re: "Flickering" speedo needle
« Reply #7 on: July 17, 2016, 10:53:05 PM »
 :) :) :) :) :) :)  I installed the used OE speedo this morning.  No more "flicker" !!!  i have dealt with this issue since "05 when I swapped out a leaking, hard shifting 700r4 for an Autogear M22W.

Like is good !!  Dave