CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
April 18, 2014, 06:02:08 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
97148 Posts in 11687 Topics by 4578 Members
Latest Member: ronhill
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Restoration
| | |-+  67 327 motor restart
« previous next »
Pages: [1] Print
Author Topic: 67 327 motor restart  (Read 482 times)
67rs327
Member
***
Posts: 39



View Profile
« on: August 20, 2013, 01:47:40 PM »

Q: I'm working thru the external mechanicals (fluids, hoses, rad cleaning, etc) of my L30/M20 that was in storage for 28 years. Have it running good but now thinking - should I consider doing anthing with the oil pump?(has good pressure on the gauge). What else should I consider? Running good like I said- but I've been taking it easy & running for a few minutes to maybe 10-15 minutes at a time. No rush - would like to drive a little as i put together a restoration plan. Thanks
Logged

1967rs L30/M20 Bolero Red - LOS 11A.
Chris - New Hampshire.
69Z28-RS
Hero Member
*****
Posts: 1943


owner since '76


View Profile Email
« Reply #1 on: August 20, 2013, 01:55:40 PM »

I know of no reason to suspect the 'oil pump' might fail.   

Have you ever seen the insides of a chevy oil pump?  they are very simple.   If it has oil in it, it's self lubricating, and if it has good pressure, then it's working as it should.   About the only issues I've ever heard of with a factory small block chevy oil pump, is the pickup coming out of the pump, and the probability of that in a street car has to be infinitesimal...

Run it til the oil is hot and well circulated, then drain the old oil (check for foaming or water?).. then fill with new oil.... make sure you have enough, but not too much.. Smiley
Logged

Gary W.  /  69Z28-RS, 72 B 720 cowl console rosewood all tint
69 Corvette convertible, silver/black 350 hp,
60 Corvette white/red, 72 Corvette coupe (2), 
90 ZR1 red/red #246, 90 ZR1 white/gray #2466
72 El Camino, '55 Nomad, '57 Nomad, '57 B/A Sedan
z28z11
Member
***
Posts: 449


View Profile
« Reply #2 on: August 21, 2013, 08:36:24 AM »

Run it til the oil is hot and well circulated, then drain the old oil (check for foaming or water?).. then fill with new oil.... make sure you have enough, but not too much.. Smiley


I agree with Gary - I would also recommend you use an oil that still has the zinc and phosphorus additiives, like Rotella or one of the specialty oils from a cam manufacturer /aftermarket. Flat tappets don't like the newer oils -

Regards,
Steve
Logged

1968 Z28 BRG/W
1969 Z28 X77 LeMans/W
1969 X66 L78 Cortez/BVT
1969 Z11 L48
Kelley W King
Member
***
Posts: 258


View Profile Email
« Reply #3 on: August 21, 2013, 11:23:27 AM »

I recently started an engine that had set since 06. Icould not read anything on the dipstick even after adding oil. My haste got me and I tryed to start it and bumped it then it locked up. I pulled the plugs and found engine oil in the cylinders. Having come to my senses I drained the oil pan to find several gallons of water. New plugs and oil and I have drove it several hundred miles with no problems except an occasional lifter sticking.
Logged

69 Z28 RS
69 SS L78
67 SS Chevelle
64 Corvette
66 GTO Tiger Gold
77 Trans Am Special Edition
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.079 seconds with 17 queries.