CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
September 01, 2014, 06:34:43 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
103754 Posts in 12185 Topics by 4697 Members
Latest Member: bobs67
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Maintenance
| | |-+  '69 horn wiring
« previous next »
Pages: [1] Print
Author Topic: '69 horn wiring  (Read 1067 times)
Springer Tom
Member
***
Posts: 39


View Profile Email
« on: September 02, 2012, 08:27:40 PM »

Could someone please explain how the 2 wires from the horn buttons on a '69 2 spoke wheel connect to the column? I have a spring and a metal button also.....this car is making me dumb Shocked
Logged
BlackoutSteve
Member
***
Posts: 398


138139883
View Profile Email
« Reply #1 on: September 03, 2012, 06:37:27 AM »

Not explained in UPC12-C1 & C5?
Logged

Restoring my RHD 69 Jane in Melbourne, Australia.
http://www.usmuscle.com.au/Forum/showthread.php?t=2840
Springer Tom
Member
***
Posts: 39


View Profile Email
« Reply #2 on: September 03, 2012, 07:32:20 AM »

Yeah Steve, I got all that, but the spring and contact don't fit in the sleeve when you put the little grommet with the wires in it....for now I left the contact pin out, I 'm wondering if the contact is too long....
Logged
Everett#2390
Member
***
Posts: 81


^Jake


View Profile Email
« Reply #3 on: September 03, 2012, 08:31:01 AM »

Is the spring too big to fit into the hole?
I would imagine the contact fits into the hole above the spring and twist & lock into place?
Logged

A flashlight is a case for dead batteries.
tmodel66
Hero Member
*****
Posts: 1212


View Profile Email
« Reply #4 on: September 03, 2012, 09:21:57 AM »

Hey Tom are you using a repop horn button and turn signal switch? If you are they are wrong and will not work.
Logged

Daniel  
'69 SS 350/4 speed  Fathom Green--POP
Springer Tom
Member
***
Posts: 39


View Profile Email
« Reply #5 on: September 03, 2012, 09:37:12 AM »

Well that explains it, I should be used to this crap by now >:(who has the correct ones?
Logged
tmodel66
Hero Member
*****
Posts: 1212


View Profile Email
« Reply #6 on: September 03, 2012, 11:43:24 AM »

I took 2 and made 1. I used the bottom half of my new one and the upper half of my old one. I couldn't find a plug and play switch.  Good luck with that.  The long tube that the horn wire plugs into is wrong and doesn't have the locking notch and is too tall for the wheel to set on. I used this part off my old one.
Logged

Daniel  
'69 SS 350/4 speed  Fathom Green--POP
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.28 seconds with 18 queries.