Author Topic: '69 LM1 ground strap locations  (Read 864 times)

Gardner

  • Newbie
  • *
  • Posts: 9
  • 69 Olympic Gold RS
    • View Profile
'69 LM1 ground strap locations
« on: December 06, 2011, 10:24:34 PM »
Hello, I just reinstalled the LM1 in my '69 RS and think I have the ground straps in the wrong locations. I just attached them to the valve covers temporarily. Can anyone tell me where they are really supposed to go? I don't have the service manual yet.

I also need the correct coil bracket if anyone has a pic of what that looks like. Thank's for the help
'69 RS

Mark

  • CRG Member
  • *****
  • Posts: 994
    • View Profile
Re: '69 LM1 ground strap locations
« Reply #1 on: December 07, 2011, 03:43:39 AM »
Passenger side runs from the firewall to the inner rear RH valve cover bolt, under the spark plug loom support.  Drivers side runs from the firewall to the outboard rear LH valve cover bolt also under the spark plug loom.
Mark C.
1969 Indy Pace Car
350/300HP RPO Z11

srode

  • Member
  • ***
  • Posts: 173
    • View Profile
Re: '69 LM1 ground strap locations
« Reply #2 on: December 07, 2011, 11:29:38 AM »
The third strap goes on the PS from the Firewall to Frame mount box to the subframe.  This one has closed ends on each end, the valve covers have 1 open and 1 closed end with the open end to the valve cover.
Steve - 02D Z11 and a Plain Jane hardtop

Gardner

  • Newbie
  • *
  • Posts: 9
  • 69 Olympic Gold RS
    • View Profile
Re: '69 LM1 ground strap locations
« Reply #3 on: December 07, 2011, 04:19:06 PM »
Thanks guys, it looks like I have them in the right place after all. Regarding the wire looms; I've lost them through a few moves. Were these stamped steel parts shared with any other cars of the same vintage? Maybe I could salvage them from parts cars/engines.
'69 RS