CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
August 21, 2014, 05:04:04 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
103324 Posts in 12155 Topics by 4691 Members
Latest Member: 67Nick
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  General Discussion
| | |-+  Cowl induction woes
« previous next »
Pages: [1] Print
Author Topic: Cowl induction woes  (Read 2168 times)
MickyT
Newbie
*
Posts: 4


View Profile Email
« on: June 13, 2006, 01:13:56 AM »

We thought it would be kinda cool to run the whole cowl induction setup with the cowl hood - air cleaner, flapper, solenoid etc on the 67. It was originally a 210 HP 327. When I ordered the kit the choice was either a quadrajet setup for 350 or the 302 Holley one. We are running a 327 with the RPM manifold and 670 Holley Avenger which the supplier said was close to the intake manifold and Holley on the original 302. You guessed it the hood wont close, too high. So did I get the wrong one sent to me or......I used the energy suspension motor mounts for a 327. I think I read somewhere that the 302 and 350 used a different mount which Im guessing includes the towers mounted on the subframe. Do those motors sit lower in the subframe. Anybody have a 327 with functional cowl induction? TIA.
Logged
Mark
CRG Member
*****
Posts: 933



View Profile Email
« Reply #1 on: June 13, 2006, 05:29:42 AM »

The 302 air cleaner spacer ring is about 2" high, the 350 ring is about 4" high, so if you have a 2" high ring and the hood won't close, you have no option except to cut the ring down to the proper height (or remove it).  If you got a 4" high ring then ou have the wrong one.
Logged

Mark C.
1969 Indy Pace Car
350/300HP RPO Z11
MickyT
Newbie
*
Posts: 4


View Profile Email
« Reply #2 on: June 13, 2006, 12:28:59 PM »

Any idea if the motor mounts are part of the problem? Seems strange otherwise that it doesnt fit. I have the 2" ring and the lower housing seems to sit quite low over the carb so I dont see that being the problem. Even with only the lower housing on it doesnt quite close. Strange...
Logged
Mark
CRG Member
*****
Posts: 933



View Profile Email
« Reply #3 on: June 13, 2006, 04:28:52 PM »

What part of the air cleaner is hitting the hood?  Is it sitting all the way down on the carb.  Do you have tower type raditor hose clamps?  Many a person has found out that the air cleaner housing is actually hitting the radiator clamp on the thermostat housing and it is not sitting all the way down on the carb body.
Logged

Mark C.
1969 Indy Pace Car
350/300HP RPO Z11
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.081 seconds with 18 queries.