Author Topic: Power glide to 400 turbo  (Read 1709 times)

Kelley W King

  • Member
  • ***
  • Posts: 363
    • View Profile
Power glide to 400 turbo
« on: May 21, 2010, 11:00:47 AM »
I have a colum shifter that was a power glide. I have now a 400 turbo and it will not go to 1st gear only 2nd. Does anyone know what stops it or how I can adjust it?
69 Z28 RS Scuncio Hi Performance
69 SS L78
67 SS Chevelle
64 Corvette
66 GTO Tiger Gold
77 Trans Am Special Edition

tom67

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Power glide to 400 turbo
« Reply #1 on: January 09, 2011, 08:36:59 PM »
Kelly did you find an answer to your post? I have the same set up but have not driven the car yet. I know some of the linkage, and pivot are different part numbers than the PG. I have been looking for the correct parts (one of the reasons I haven't driven it) but cant find them. May just have to go with a Lokar linkage and keep looking for the correct parts.

Kelley W King

  • Member
  • ***
  • Posts: 363
    • View Profile
Re: Power glide to 400 turbo
« Reply #2 on: January 10, 2011, 03:28:54 PM »
No one has given me the answer. A friend thinks the trans linkage connection is the problem but I have not found a part to work yet. I did play with the adjustments and got it into low but now it does not go into park correctly. I am installing a car lift soon and get back on it with out laying on the floor.

Gramps69Z

  • Hero Member
  • *****
  • Posts: 625
  • 69 X33 D80
    • View Profile
Re: Power glide to 400 turbo
« Reply #3 on: January 10, 2011, 04:30:02 PM »
The problem is you're going from a two-speed auto to a three-speed. The linkage and shifter will have to be changed.
Captain John Wykoff
Destin Fire     5 months  to go

I'm sick and tired of mismanagement and disappointment. 
I'm a COWBOYS fan.