CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
October 22, 2014, 08:39:58 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
105661 Posts in 12338 Topics by 4753 Members
Latest Member: stpatrick
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Restoration
| | |-+  Gas Tank
« previous next »
Pages: [1] Print
Author Topic: Gas Tank  (Read 909 times)
sixt9x33rs
Hero Member
*****
Posts: 841



View Profile
« on: June 26, 2009, 06:18:35 AM »

I had to put a new tank in my 69 Z the old one had a hole in it.

I know that the tanks are suppose to be 18.5 gallons but I think mine may be a little smaller? It seems to fit like the original, but I recently put in only 12.5 gallons of gas in the tank while the needle was reading 1/8 of a tank? I would have expected to put in more like 15 gallons. I guess the sending gauge could be off or the needle off but was wandering if anyone else has experienced this.

Also my low fuel light use to come on at 1/8 of a tank and now it will not lite up at that level. I have not run the car with much less fuel than that so it still may lite up? It also use to lite up when I went around a turn with low fuel and nothing now. I did take my gauges out of the car when I did the work maybe something came unplugged? Any ideas on this would be helpful too.

Thanks,
Logged

'69 RS Z/28 Olympic Gold, 711
Flat hood no spoiler, black top, endura, 4:10
POP 39,000
69 X77 Z/28 69 711 Original Paint Unrestored
'69 X66 Convertible Cortez Silver 712 black top Endura, auto, bumper guards, am/fm rear speaker 44k miles
Mark
CRG Member
*****
Posts: 944



View Profile Email
« Reply #1 on: June 26, 2009, 11:06:32 AM »

Probably bent the float arm that the sensor works off of either taking it out and putting it back into the tank so now its off by a little bit.
Logged

Mark C.
1969 Indy Pace Car
350/300HP RPO Z11
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.089 seconds with 17 queries.