Author Topic: 69 Headlamp Problem  (Read 2991 times)

timhahn

  • Newbie
  • *
  • Posts: 8
    • View Profile
69 Headlamp Problem
« on: November 17, 2008, 04:55:03 AM »
I am having a problem with my headlights. When they are on low beam they will not work but when I switch them to the high beams they work fine. Any ideas or suggestions?

77thor

  • Member
  • ***
  • Posts: 239
    • View Profile
Re: 69 Headlamp Problem
« Reply #1 on: November 17, 2008, 12:15:46 PM »
Most likely it's the headlight dimmer switch on the floor.
Those things are notorious for going bad.
1969 Camaro SS350, M21, 12 Bolt, 01B LOS Build

tom

  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • Discount Internet Services
Re: 69 Headlamp Problem
« Reply #2 on: November 17, 2008, 12:28:50 PM »
Not probable, but since different filaments are used for low beam and high beam, it is possible both low beam filaments are out.
69 X11 Z21 L14 glide
looking for a 69 export model (KPH) speed
o

timhahn

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: 69 Headlamp Problem
« Reply #3 on: November 19, 2008, 09:46:07 PM »
Thanks for the help! I have an extra headlamp which will allow me to check the bulb first. I still think it is the floor switch but I have an easy way of checking the bulb.

mrdetails

  • Member
  • ***
  • Posts: 164
    • View Profile
Re: 69 Headlamp Problem
« Reply #4 on: December 30, 2008, 12:31:09 AM »
I had the same problem and it was the switch. The bulbs are a pain to change. Remove the connector from the switch and jump the middle terminal to either end with a piece of wire to check. You should be able to "peal" the carpet back without removing the kick panel.
Good Lucl

77thor

  • Member
  • ***
  • Posts: 239
    • View Profile
Re: 69 Headlamp Problem
« Reply #5 on: June 12, 2009, 11:17:24 AM »
Weird. I found the issue with my 69 Camaro....
if I pulled back the carpet to expose the dimmer switch, my headlights would work OK (standard & high-beams).
Apparently the switch was hanging up on the rubber carpet grommet. I pulled that grommet out of the carpet, re-installed, and it works great now.
1969 Camaro SS350, M21, 12 Bolt, 01B LOS Build