CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
October 21, 2014, 10:12:31 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
105626 Posts in 12335 Topics by 4753 Members
Latest Member: stpatrick
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Maintenance
| | |-+  Please help--'68 door window adjustment...
« previous next »
Pages: [1] Print
Author Topic: Please help--'68 door window adjustment...  (Read 1388 times)
hotrod68
Hero Member
*****
Posts: 520


almost finished

rusticman48@aol
View Profile Email
« on: November 05, 2007, 11:03:55 PM »

   Tonight I put the driver's-side door window back in my '68, and all is not well--unlike the passenger side installation, which went off without a hitch. I'm using the original glass, tracks, sashes..etc. The only non-original items are the window mounting plates w/rollers and the regulator.
   When I bolted the glass to the regulator I had to push the sash out onto the window studs, and the glass is very hard to roll up and down and binds severely in the tracks. During the middle half of it's travel it cocks in hard against the inside fuzzy guides for no apparent reason. I tried every adjustment to make, and nothing made any difference. I compared the new repro regulator and window mount plates against the originals, and they appear indentical. I have virtually no experience with windows other than the other 3 which went back in perfectly. Could the repro regulator be the culprit, or am I just overlooking something simple? Any help would be greatly appreciated. Thanks. 

 
Logged

HotRod'68  1968 SS350 coupe undergoing frame-off resto/rod. 386/350/4.11s
Butternut Yellow    black standard interior
fireZ
Hero Member
*****
Posts: 548



View Profile
« Reply #1 on: November 06, 2007, 08:41:48 AM »

Try backing off  all the mounting bolts off until they are just holding the window in place. Now try to slowly put the window up pulling it on the correct path as you turn the crank. i had one on my 68 that was a true test of my temper. It did work out but it took a bit of work. Good luck
Logged

1968 Z28 LA Built
LIC # RPO Z28
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.072 seconds with 17 queries.