CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
July 31, 2014, 10:38:30 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
102512 Posts in 12092 Topics by 4669 Members
Latest Member: paulmanta
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Maintenance
| | |-+  4-way Flasher problem...
« previous next »
Pages: [1] Print
Author Topic: 4-way Flasher problem...  (Read 1814 times)
ironman24
Member
***
Posts: 62



View Profile Email
« on: August 27, 2007, 12:02:49 PM »

Hi guys,
  I have a problem with my flashers on my 67.  They dont work!  All other lights on the car work fine.  I have replaced the flasher unit in the upper right corner of the fuse box and nothing.  Could my problem be in the steering column?  One thing i did notice is when the flasher button is pressed in my blinkers dont work.  if i pull the button out the blinkers will work.  Any idea's on where i should be looking and what to do??
thanks,
Charlie
Logged
ironman24
Member
***
Posts: 62



View Profile Email
« Reply #1 on: August 29, 2007, 11:12:55 PM »

No more 4-way flasher problem.  I figured for the hell of it I would try another flasher unit. So I picked one up at another parts store and put her in and guess what.........
IT WORKED!!!!!!!  Now I have Flashers!!!
« Last Edit: August 29, 2007, 11:14:56 PM by ironman24 » Logged
hotrod68
Hero Member
*****
Posts: 518


almost finished

rusticman48@aol
View Profile Email
« Reply #2 on: September 02, 2007, 09:29:35 PM »

GO Ironman, GO!!!
Logged

HotRod'68  1968 SS350 coupe undergoing frame-off resto/rod. 386/350/4.11s
Butternut Yellow    black standard interior
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.064 seconds with 17 queries.