CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
September 01, 2014, 02:17:05 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
103764 Posts in 12186 Topics by 4698 Members
Latest Member: Ed miles
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Maintenance
| | |-+  Windshield Washer Pump Piston
« previous next »
Pages: [1] Print
Author Topic: Windshield Washer Pump Piston  (Read 2812 times)
WMCC AL
Newbie
*
Posts: 16

WMCC Membership Coordinator


View Profile Email
« on: May 27, 2007, 02:31:31 PM »

Help! Does anyone know where I can locate a new or good used used windshield washer plunger? piston? and seal for my 68 Camaro. It seems all the repair kits that I have found do not include the part I need the most.  Any ideas?
Logged

WMCC - Membership Coordinator
WMCC AL
Newbie
*
Posts: 16

WMCC Membership Coordinator


View Profile Email
« Reply #1 on: May 29, 2007, 12:46:37 PM »

Hasn't anybody ran into this before?
Logged

WMCC - Membership Coordinator
sam
Member
***
Posts: 232


View Profile Email
« Reply #2 on: May 29, 2007, 01:37:50 PM »

I would say contact a wiper motor rebuild shop. Maybe Wiper Works? I believe they also rebuild the washer pump too.
Logged
Wallace
Member
***
Posts: 20


View Profile
« Reply #3 on: May 29, 2007, 02:09:47 PM »

Try classicindustries.com.  If all else fails, you can at least replace the entire pump.


Wallace
Logged
KevinW
Member
***
Posts: 406


View Profile Email
« Reply #4 on: May 29, 2007, 08:09:38 PM »

I have taken pumps apart to see how they tic, the plunger part is not reproed. Neither is the seal that mounts on the plunger.  What is wrong with yours?
Logged
WMCC AL
Newbie
*
Posts: 16

WMCC Membership Coordinator


View Profile Email
« Reply #5 on: May 30, 2007, 07:15:46 AM »

I have taken pumps apart to see how they tic, the plunger part is not reproed. Neither is the seal that mounts on the plunger.  What is wrong with yours?

My plunger, seal, and spring are missing from mine.  I have the original wiper pump assy. and would like to restore it.
Logged

WMCC - Membership Coordinator
KevinW
Member
***
Posts: 406


View Profile Email
« Reply #6 on: May 30, 2007, 03:44:20 PM »

I should have extra parts, let me look around.
Logged
WMCC AL
Newbie
*
Posts: 16

WMCC Membership Coordinator


View Profile Email
« Reply #7 on: May 30, 2007, 09:42:28 PM »

That would be greatly appreciated.  Let me know if you locate the parts I need and what you want for them, if you find 'em.
Logged

WMCC - Membership Coordinator
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.205 seconds with 17 queries.