Author Topic: Wiper Motor quit working  (Read 2882 times)

MyRed67

  • Hero Member
  • *****
  • Posts: 805
  • SZZLN 67
    • View Profile
Wiper Motor quit working
« on: June 28, 2020, 01:44:49 AM »
Ok, for you electrical guys.   My Windshield wipers have worked the past 8 summers, since I put the car back on the road.   I went to use the wipers last weekend, cuz we got a little rain.   Wipers don't work in the 2 on positions.   They will make one pass if I push the button for washers.   The fuse is good (juice both sides), and I have juice to all wires at the motor, except for the Dark Blue one.  What is the issue?
1967 Camaro  LOS  11A
Original Engine   Z - Tribute
Mike C.    NW - Illinois

z28z11

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
Re: Wiper Motor quit working
« Reply #1 on: June 28, 2020, 07:24:19 PM »
Has to be either the switch or the terminal board - the fact that the motor runs in the wash position helps rule out bad brushes in the motor itself. Try the switch first, make sure it's not a bad position contact, and then move to the terminal board, which is available like this one on eBay. You can run a 12V fused jumper to the blue wire terminal with the switch on, if it activates you can pinpoint it back. Hopefully it's just an old switch -

Regards,
Steve

https://www.ebay.com/itm/1962-1980-Chevy-Olds-Buick-Windshield-Wiper-Motor-Terminal-Board-NOS-Delco/202864660185?hash=item2f3bad0ed9:g:Z04AAOSw0J9bIHGQ
1968 Z28 M21/U17 BRG/W 1967 Chevy ll Nova SS 
1969 Z28 X77/M20/VE3 LeMans/W
1969 L78 X66/N66 Cortez/BVT
1969 Z11 L48/M35/C60/C06  1949 3100 5wd 235/6

L78racer

  • Member
  • ***
  • Posts: 80
    • View Profile
Re: Wiper Motor quit working
« Reply #2 on: June 28, 2020, 07:33:12 PM »
turn the key on. turn the wipers on. take a rubber mallet and rap on the wiper motor. it will probably start working. brushes stuck.
Paul

mgreenz

  • Member
  • ***
  • Posts: 71
    • View Profile
Re: Wiper Motor quit working
« Reply #3 on: June 28, 2020, 07:37:25 PM »
I recently had the same issue. It turned out to be a bad switch ground. After the switch, motor and pump bench tested good I cleaned up the back side of the dash at the switch. Wipers worked fine after that.
___
Terry

169INDY

  • Hero Member
  • *****
  • Posts: 1813
    • View Profile
Re: Wiper Motor quit working
« Reply #4 on: June 28, 2020, 08:08:37 PM »
I recently had the same issue. It turned out to be a bad switch ground. After the switch, motor and pump bench tested good I cleaned up the back side of the dash at the switch. Wipers worked fine after that.


This is exactly my problem for years on my 68, Only would run when the wiper button was depressed.

My fix was to take the switch out of the dash and VERY carefully Tap and UN Crimp the Zinc switch housing in three places and disassemble the switch taking notes, cleaning with electronics cleaner and iso alcohol and burnishing or polishing ALL the stationary and moving contacts using rubberized abrasive (Or a common eraser). Then Light white lithium lube the assy and reassemble and re crimp with Hammer and drift.

DIY with NO costs.

Jim
Jim
68 SS/RS L35 Th-400 LOS
69 Pace Car L48 Th-350 LOS
68 Z28 M21 LOS