Author Topic: Electrical Issue  (Read 887 times)

JBall

  • Newbie
  • *
  • Posts: 6
  • 5133059479
    • View Profile
Electrical Issue
« on: September 25, 2016, 09:58:52 PM »
Hello,

I have an issue with my '68 Camaro and was wondering if anyone here might have an idea as to what's wrong.

Background:
Took the car for a quick spin around the block. Stopped at a light and when it was my turn to go, I took off fine.. shifted into 2nd and lost all power..

After a ride on the roll back, the car is back in the garage.

Things I tried:
Replaced the coil - No good
Replaced the MSD 6AL box no good
Checked the magnetic pick up in the distributor with an ohm meter, and it seems to be in spec.
Replaced the rotor button. Was quite crispy

Checked the fuse box and found that the fuse marked "dir sig" and "back up" fuse was blown. The red ignition wire from the MSD box is plugged in to a terminal to the left of this. Replaced the fuse and soon as I turned the key it popped.

I moved the red MSD wire to the accessory terminal and now I have spark at the coil. Car still will not start. Turns over fine. The fuse still blows as soon as you hit the key.

I'm at a loss.

Any ideas would greatly be appreciated.

Thanks,

Jason Ball



69Z28-RS

  • Hero Member
  • *****
  • Posts: 4428
  • owner since 4-Apr-1976
    • View Profile
Re: Electrical Issue
« Reply #1 on: September 26, 2016, 03:42:15 AM »
If the large electrical plug thru the firewall isn't making good connections, that *might* be your issue???

Gary W / 09C 69Z28-RS, 72 B 720 cowl console rosewood tint
69 Corvette convertible, silver/black 350 hp,
60 Corvette white/red, 72 Corvette coupe, '70 Mach I 
90 ZR1 red/red #246, 90 ZR1 white/gray #2466
72 El Camino, '55-'56-'57 Nomads, '55-'57 B/A Sedan

JBall

  • Newbie
  • *
  • Posts: 6
  • 5133059479
    • View Profile
Re: Electrical Issue
« Reply #2 on: September 26, 2016, 01:16:11 PM »
Ok,

I will take a look tonight.

Thanks for the response.

Jason

Spooky

  • Member
  • ***
  • Posts: 68
    • View Profile
Re: Electrical Issue
« Reply #3 on: September 26, 2016, 09:28:45 PM »
I think the red and black msd box wires go right to the battery.

Scott

KurtS

  • CRG Coordinator
  • *****
  • Posts: 4447
    • View Profile
Kurt S
CRG