Author Topic: 69 Z Fuel Pump  (Read 992 times)

sixt9x33rs

  • Hero Member
  • *****
  • Posts: 940
    • View Profile
69 Z Fuel Pump
« on: August 01, 2016, 01:53:14 AM »
Guys,

I believe the FP in my Z is going bad. Is there a certain one that you guys would recommend?


Thanks

Lawrence
'69 RS Z/28 Olympic Gold, 711
Flat hood no spoiler, black top, endura, 4:10
POP 39,000
69 X77 Z/28 69 711 Original Paint Unrestored
'69 X66 Convertible Cortez Silver 712 black top Endura, auto, bumper guards, am/fm rear speaker 44k miles

william

  • CRG Member
  • *****
  • Posts: 1810
    • View Profile
Re: 69 Z Fuel Pump
« Reply #1 on: August 01, 2016, 09:47:58 PM »
I've heard many aftermarket pumps are defective, putting out 10 psi.

GM Performance sells a street performance pump, #6415325. Has a 7 psi shutoff and is rated at 30 gph. Doesn't quite look OE but aftermarket pumps don't either. 

sixt9x33rs

  • Hero Member
  • *****
  • Posts: 940
    • View Profile
Re: 69 Z Fuel Pump
« Reply #2 on: August 01, 2016, 09:57:12 PM »
Thanks William will check it out.
'69 RS Z/28 Olympic Gold, 711
Flat hood no spoiler, black top, endura, 4:10
POP 39,000
69 X77 Z/28 69 711 Original Paint Unrestored
'69 X66 Convertible Cortez Silver 712 black top Endura, auto, bumper guards, am/fm rear speaker 44k miles

z28z11

  • Hero Member
  • *****
  • Posts: 1069
    • View Profile
Re: 69 Z Fuel Pump
« Reply #3 on: August 02, 2016, 02:43:25 AM »
Bought mine at Napa - make sure you get the Made in USA pump. They must have demilled the pressure die cast mold - you can still see the "GM" casting outline on the side of the pump housing. Looks right, fits and works perfectly, just doesn't have the GM logo.

Just my $.02 -

Regards,
Steve

1968 Z28 M21/U17 BRG/W
1969 Z28 X77/M20/VE3 LeMans/W
1969 L78 X66/N66 Cortez/BVT
1969 Z11 L48/M35/C60/C06

Fred Mertz

  • Member
  • ***
  • Posts: 51
    • View Profile
Re: 69 Z Fuel Pump
« Reply #4 on: August 18, 2016, 04:50:37 AM »
I recently had a fuel pump from NAPA auto parts.  I was having drivability problems along with a gas smell when driving a highway speeds.  It turned out to be the fuel pump. I put a pressure guage on it and it read 9.5 lbs. of pressure.  I solved the problem by adding a regulator. I mounted it to the front of the cylinder head using one the accessary holes.