CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
September 22, 2014, 11:19:41 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
104664 Posts in 12245 Topics by 4719 Members
Latest Member: Baconcks
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Model Specific Discussions
| |-+  6-cylinder Camaros
| | |-+  speedometer cable problem
« previous next »
Pages: [1] Print
Author Topic: speedometer cable problem  (Read 146 times)
Kasper
Newbie
*
Posts: 1


View Profile Email
« on: June 16, 2014, 08:31:18 PM »

We have a 67 convertible (6 cyl/3-spd on floor) much has been mostly redone but am having trouble with the speedometer which "jumps all over the place around 30mph". Is smooth below 30 and above 40. Have replaced the head - no difference. Removed the cable - 2 parts with a square metal box connected between the 2 cables - nothing on the box other than the 2 connectors. Think I need a replacement but am confused by the replacement cables listed - 1 upper and 1 lower listed which match the lengths of what I removed and then there are a couple single length ones. Not sure what to do.... Replace exactly what I removed (what would that metal box be for?)? Replace with a single length? or....? How/why we have this car is another story.  Thanks
Logged
Ed Bertrand
CRG Member
*****
Posts: 2333


View Profile
« Reply #1 on: June 16, 2014, 09:54:26 PM »

According to the AIM (UPC 12, sheet C3) you should have the single piece cable, P/N 3917926 (or optionally, P/N 6476646). Not sure what the "square metal box" is. Can you post a picture of it?

Ed
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.078 seconds with 18 queries.