CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
August 29, 2014, 07:16:58 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
103655 Posts in 12181 Topics by 4697 Members
Latest Member: greygoose01
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Maintenance
| | |-+  67 camaro fuel gauge problem
« previous next »
Pages: [1] Print
Author Topic: 67 camaro fuel gauge problem  (Read 574 times)
x77-69z28
Hero Member
*****
Posts: 787



View Profile
« on: May 19, 2014, 10:34:29 AM »

My 67 RS/SS with console gauges fuel gauge has stopped working. Any ideas? I think it is a ground problem as it is pinned fast full. Yet, I ran out of gas!
Buddy
Logged

69 x77 burnished brown, 711 int 05A bought in 78
67 rs/ss 350 butternut yellow 4 speed 2nd owner
70 Z28 forrest green, green int, M40, bk vinyl roof PROJECT
99 SS hugger orange 6spd NO TTOPS bought new 1 of 54
11 cts-v blk diamond  edition wagon 556hp sick!
janobyte
Hero Member
*****
Posts: 695


1968 z/28

bajcer@msn.com
View Profile Email
« Reply #1 on: May 19, 2014, 08:57:58 PM »

check the ground ,only problem I ever had was once in a great while had to clean the ground by the tank. Use a little dielectric grease. Still retains the OE sending unit which works fine. Into a 46 yo S.W. gauge.
Logged
68ashgoldRS/SS
Member
***
Posts: 77



View Profile
« Reply #2 on: May 20, 2014, 12:58:11 PM »

Yes, hopefully it's just the ground as janobyte describes... I went through this a few months back and discovered that I was not so lucky..  the Fuel sending unit in the tank had gone bad.  Here's my post troubleshooting this.  http://www.camaros.org/forum/index.php?topic=11830.msg96919#msg96919
Hope this helps, Ed
Logged

Ed Denney from South Jordan Utah

1968 Camaro RS/SS -Restored
1931 Ford 5 Window Coupe, Chopped  -Project
1965 Corvette Stingray -Project
1956 Dodge D100 Pickup -Project
1936 US Soldier, Dad -Best Friend
69pace
Member
***
Posts: 373



View Profile
« Reply #3 on: May 20, 2014, 09:51:38 PM »

Yes - check the sender ground first. You can troubleshoot the sender, harness and gauge following the troubleshooter over at TC: http://www.camaros.net/forums/showthread.php?t=195833
Logged

1969 Z-11 350/300 with 4 Speed
x77-69z28
Hero Member
*****
Posts: 787



View Profile
« Reply #4 on: May 21, 2014, 10:49:10 AM »

Thanks guys, I will let you know how I make out.
Logged

69 x77 burnished brown, 711 int 05A bought in 78
67 rs/ss 350 butternut yellow 4 speed 2nd owner
70 Z28 forrest green, green int, M40, bk vinyl roof PROJECT
99 SS hugger orange 6spd NO TTOPS bought new 1 of 54
11 cts-v blk diamond  edition wagon 556hp sick!
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.337 seconds with 18 queries.