Author Topic: Dies on hard acceleration - Carb has odd vacuum sound (67 350)  (Read 3380 times)

67L48

  • Member
  • ***
  • Posts: 50
    • View Profile
Dies on hard acceleration - Carb has odd vacuum sound (67 350)
« on: September 08, 2006, 01:19:40 PM »
67 350 w/ Powerglide. All original components - Rochester 4 bbl carb.  Was originally equipped with the CA smog equipment, but that is not installed today.

When I accelerate at a "normal" rate, the car behaves fine.  When I accelerate quickly, the car bogs.  If I keep the pedal down, it will die.  I just pulled the air cleaner off and was playing with the carb a bit.  I noticed that when I accelerated, I heard a very loud vacuum leak/release (not audible inside the cab).  When I accelerated slowly ("normal"), there was no vacuum leak/release.  I know nothing about carbs, so maybe this is normal.  I couldn't locate exactly where the vacuum leak/release was coming from, so I couldn't plug it and see what happened.

I don't mind buying a book and trying to do work myself (I've always wanted to learn about carburetors), but just thought I'd ask if this symptom rings any bells among the experts here.

Thanks.

K. A. Young
1967 Camaro SS 350
Fort Collins, CO

CNorton

  • Member
  • ***
  • Posts: 190
    • View Profile
Re: Dies on hard acceleration - Carb has odd vacuum sound (67 350)
« Reply #1 on: September 08, 2006, 03:51:07 PM »
If you're dealing with a Rochester Quadrajet you may wish to check the dashpot on the passenger side, front of the carburetor.  It controls the secondary air-door.  Many of those have plastic housings and they can develop vacuum leaks as they age (as do many of we senior citizens).  Even those with metallic housings can experience ruptured or deteriorated diaphrams.  If the dashpot isn't working there is no control over the actions of the secondary air-door other than the tension on the spring under the linkage connection at the upper rear of the carburetor.  If the dashpot is malfunctioning and if the spring is too loose, for example, the door will open too soon (before vacuum has a chance to build during acceleration) and a bog will occur.  If the bog is bad enough, the engine will sputter and die.  If the spring is too tight there will be a flat spot in the acceleration curve.  The dashpot and the spring need to work in conjuction.

If you are dealing with a Rochester carburetor other than a Quadrajet, please disregard the foregoing.


hotrod68

  • Hero Member
  • *****
  • Posts: 520
  • almost finished
    • View Profile
Re: Dies on hard acceleration - Carb has odd vacuum sound (67 350)
« Reply #2 on: September 09, 2006, 03:18:37 AM »
If yer dealing with a Quadrajunk, toss it and get a Spread-Bore Holley!  Seriously, it sounds to me like a very lean condition like CNorton said. Just for the hell of it, take the fuel line off and see if the bronze filter is in backwards--if it has one. The cone of the filter should be pointed at the fuel line, not the blunt end of the filter. A reversed filter will allow just enough gas to let the engine run great at idle, but stall under load. This comes to mind because my cousin installed a fuel filter on a dump truck backwards AND left a vacuum tap unplugged as well. A freak incident to be sure, but you never know. Good luck.
HotRod'68  1968 SS350 coupe undergoing frame-off resto/rod. 386/350/4.11s
Butternut Yellow    black standard interior