CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
October 21, 2014, 04:39:47 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
105618 Posts in 12334 Topics by 4753 Members
Latest Member: stpatrick
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Originality
| | |-+  '68 BB chrome valve cover question ?? (or pics if anyone has some)
« previous next »
Pages: [1] Print
Author Topic: '68 BB chrome valve cover question ?? (or pics if anyone has some)  (Read 3952 times)
KevinK
Member
***
Posts: 232



View Profile WWW Email
« on: September 12, 2006, 01:20:24 PM »

  For a '68 396 Camaro (I'm assuming it would be the same for '67)...
 
   Valve cover questions:
 
  1.) On the driver's side valve cover, ...was the wire stand all the way to the rear, ...or forward about 4-6" (in the intake side)
        (I'm wondering about clearance on the wiper motor, ...but moreso what's technically correct)
  2.) On the driver's side valve cover, ...with Power Brakes, ...was there a 'slant' for clearance of the brake booster?
         (I always thought there was, ...but just read differently...Huh)
  3.) With chrome valve covers, ...should the 'TR' screws and hardware also be "chrome"?
 
     I was looking at these on Ebay, ...but this is where many of my questions came up:
  http://cgi.ebay.com/ebaymotors/67-1967-camaro-valve-covers-BB-396-427-repros_W0QQcmdZViewItemQQcategoryZ33627QQihZ014QQitemZ330027466758QQrdZ1
 
            ...Thanks,
                            Kevin
Logged
Ed Bertrand
CRG Member
*****
Posts: 2333


View Profile
« Reply #1 on: September 12, 2006, 06:55:05 PM »

Kevin,

To answer your questions I've included a couple of pictures that might help. My covers are original and have never been rechromed, so they look a little battle worn! Note the original "flash chrome" process that's worn off and the "dents" in the cover from the drippers being welded on.

1. There are two stands on each cover. The drivers side rear spark plug wire stand is in front of the rear mounting bolt so it doesn't hit the wiper motor when removing. (See the top picture).
2. No "slant" on the Camaro big block covers, but a "dimple" on the driver side (rear) for rocker arm clearance instead. The "slant" was a Corvette thing (See the top picture).
3. Not sure about this one since my retainers and screws have been replaced, but I believe the "TR" screws are not chrome plated, but the retainers are. JohnZ will have to answer this one for you.

Edit: The big block valve cover report is now done so I've added the LINK.

Ed

Top picture is of my drivers side cover... (You can see the rear spark plug wire stand in front of the rear mounting bolt and the "dimple" at the end of the cover to the very right of the picture.)



Second picture is of my passengers side cover... (Not the original oil filler cap, sorry to say!) Note the wear spots where the chrome has worn off.



« Last Edit: August 14, 2012, 10:28:37 PM by Ed Bertrand » Logged
KevinK
Member
***
Posts: 232



View Profile WWW Email
« Reply #2 on: September 12, 2006, 07:51:49 PM »

Ed,
    THANK YOU! so much for your reply and for posting the pictures.
 
    ...Do you need a used original ("S" rivet) oil filler cap? ... I can check, ...I might have an extra. If you do, ...PM me.
   
Logged
Tinkerr
Member
***
Posts: 127


View Profile
« Reply #3 on: September 13, 2006, 01:18:29 AM »

Ed,
The valve covers on my car are supposed to be the originals and my drivers side resemble the 69 style valve covers. The car has a 04 build date any chance they started early with the 69 covers?
Logged
Mark's 68 L78 RS SS
Member
***
Posts: 117


View Profile Email
« Reply #4 on: September 13, 2006, 05:58:06 AM »

Kevin:

My car is an 06C build date and I have some pics of my valve covers with what I believe are the original fasteners.  Most are too big to post here and I haven't figured out how to down size them successfully yet but am more than willing to send them to your regular email.  I wil also be able to take more pictures Friday with a lower res camera whose pics will fit here and can take anything you want.  Let me know.

Mark

P.S. If Ed doesn't take you up on the oil filler cap I might lol  Grin
Logged

Mark
Skaneateles, NY
68 L78 RS SS M22
Mark's 68 L78 RS SS
Member
***
Posts: 117


View Profile Email
« Reply #5 on: September 13, 2006, 06:02:04 AM »

Here's hopefully a better pic

Mark
Logged

Mark
Skaneateles, NY
68 L78 RS SS M22
KevinK
Member
***
Posts: 232



View Profile WWW Email
« Reply #6 on: September 13, 2006, 06:29:44 AM »

Mark,
   Thanks for the additional photos, ...actually the 1st one clearly shows the location of the rear wire stand.
  Ed did send me an email, ...so I think he's interested if I can dig one up ...   
 
    Thanks again,
                           Kevin
Logged
JohnZ
CRG Member
*****
Posts: 4121


View Profile Email
« Reply #7 on: September 13, 2006, 10:35:23 AM »

3. Not sure about this one since my retainers and screws have been replaced, but I believe the "TR" screws are not chrome plated, but the retainers are. JohnZ will have to answer this one for you.


The chrome covers used on the Corvette had zinc/cad-plated bolts, and the small triangular reinforcements under each bolt were also zinc/cad-plated (not chrome).
Logged

'69 Z/28
Fathom Green
CRG
Tinkerr
Member
***
Posts: 127


View Profile
« Reply #8 on: September 13, 2006, 10:40:50 AM »

My left valve cover is like Marks. Now the ? is which ones are correct? Mark are you using aftermarket pulleys I noticed you have what looks like a long waterpump on a 68? Long waterpumps didn't start until 69.   tinkerr
« Last Edit: September 13, 2006, 03:09:14 PM by Tinkerr » Logged
Ed Bertrand
CRG Member
*****
Posts: 2333


View Profile
« Reply #9 on: September 13, 2006, 08:50:31 PM »

Thanks John. I knew you'd come through!!

I can't say when the change to the left cover started, but the P&A shows the following for 68 and 69 Camaro's:

68 Chevelle, Camaro - Cover Assy, Left (Chrome) - 3925567
68-69 Nova, Chevelle, Camaro - Cover Assy, Right (Chrome) - 3925574
69 All - Cover Assy, Left (Chrome) - 3947883

My car is a 05D 68, so we at least know the change didn't occur until after that. Les has a later car than I do. Maybe he can add info to this.

Ed


Logged
Steve68
CRG Member
*****
Posts: 506


View Profile
« Reply #10 on: September 13, 2006, 09:21:33 PM »

Ed

3947883 was substituted for 3925567 in May of 69.  3981016 was substituted for 3925574 in January of 71.

Steve

Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.085 seconds with 18 queries.