CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
October 20, 2014, 06:01:14 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
105569 Posts in 12328 Topics by 4751 Members
Latest Member: Blakep54
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Originality
| | |-+  evaporust on axles
« previous next »
Pages: [1] Print
Author Topic: evaporust on axles  (Read 514 times)
BillOhio
Member
***
Posts: 374



View Profile WWW Email
« on: May 02, 2013, 11:33:00 AM »

Had some crude on end of a me shafts and sat the hub end in evaporust for a day. Rinsed them off and found a big blue paint dawb on the edge of the hub. Runs from one stud to the next. Evaporust is neat stuff
Logged

1969 Z28, Burgandy, numbers matching, 12,900 miles
1967 Plymouth GTX Hemi, 4 speed, dana
1961 Chrysler 300G convertible
68camaroz28
Hero Member
*****
Posts: 970



View Profile Email
« Reply #1 on: May 02, 2013, 06:54:41 PM »

I cannot count how many parts we've used evapo-rust on from suspension parts to our driveshaft and everything in between. And yes, exactly how we found so many of our paint markings.
Logged

Chick
68 Z/28 NOR 01B Orig motor/trans/rear
69 Z/28 NOR 07A Orig Block & GM Cross-ram/carbs
69 L34 Rest. Nova Father/Son Car
69 L78 Surv Nova Purch 4/69 31K miles
67 L89 Corv Tribute
68 Corv 427/400 Orig motor
07 Corv Z06
R 68Z build- http://www.camaros.net/forums/showthread.php?t=182584
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.094 seconds with 18 queries.