CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 18, 2014, 05:33:22 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
107458 Posts in 12502 Topics by 4810 Members
Latest Member: rustoleumm
* Home Help Search Login Register
+  CRG Discussion Forum
|-+  Camaro Research Group Discussion
| |-+  Maintenance
| | |-+  69 Heater fan
« previous next »
Pages: [1] Print
Author Topic: 69 Heater fan  (Read 1172 times)
muzzy
Newbie
*
Posts: 2


View Profile Email
« on: November 10, 2012, 06:29:20 PM »

Hi,69 Camaro non A/C heater
Is the heater fan supposed to run in the off position?(key on)
All the speeds work but fan continues to run very slowly in the off position,I have heard that having the fan running all the time has something to do with the astro ventilation
All comments appreciated
Regards Murray
« Last Edit: November 10, 2012, 07:58:52 PM by muzzy » Logged
x77-69z28
Hero Member
*****
Posts: 815



View Profile
« Reply #1 on: November 10, 2012, 08:36:51 PM »

Not in 69. Astro ventilation was  just venting outside air
Logged

69 x77 burnished brown, 711 int 05A bought in 78
67 rs/ss 350 butternut yellow 4 speed 2nd owner
70 Z28 forrest green, green int, M40, bk vinyl roof PROJECT
99 SS hugger orange 6spd NO TTOPS bought new 1 of 54
11 cts-v blk diamond  edition wagon 556hp sick!
tmodel66
Hero Member
*****
Posts: 1212


View Profile Email
« Reply #2 on: November 10, 2012, 10:55:51 PM »

When it's turned off it should be completely off.
Logged

Daniel  
'69 SS 350/4 speed  Fathom Green--POP
muzzy
Newbie
*
Posts: 2


View Profile Email
« Reply #3 on: November 10, 2012, 10:59:41 PM »

Thanks guys any idea where to start looking for the fault condition?
Logged
JohnZ
CRG Member
*****
Posts: 4155


View Profile Email
« Reply #4 on: November 12, 2012, 03:26:04 PM »

Thanks guys any idea where to start looking for the fault condition?

Has to be either in the fan switch itself or two wires pinched together between the fan switch and the heater blower resistor.
Logged

'69 Z/28
Fathom Green
CRG
Mark
CRG Member
*****
Posts: 954



View Profile Email
« Reply #5 on: November 13, 2012, 02:18:25 PM »

Turning the fan to "off" on the left most lever, doesn't always turn the fan completely off.  The fan speed siwtch is attached to the back of the heater control panel and operates off a linkage that operates the dampers in front of the heater core.  When you slide that lever up to the "AIR" position the fan should stop, but if you inkage is worn, or bent the switch may never switch the fan off an the fan will continue to run in slow speed. 

AC equipped cars fans will continue to run even with the fan switch across the top of the heater control in the OFF position.  It will not shut completely off until the tmeprature cntro switch is placed in the OFF position as well.  These cars have a separate "lo Blo" switch attached to the bottom left rear of the heater control that keeps the fan running in slow until the temp control switch is turned off.  If you put the temp control switch in off, the fan won't work in any speed, as power is completely disconnected to the fan switch.
Logged

Mark C.
1969 Indy Pace Car
350/300HP RPO Z11
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.087 seconds with 18 queries.