CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
April 20, 2014, 05:59:23 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
97237 Posts in 11693 Topics by 4578 Members
Latest Member: ronhill
* Home Help Search Login Register
  Show Posts
Pages: [1]
1  Camaro Research Group Discussion / General Discussion / VIN on engine problem on: October 04, 2013, 09:39:14 PM
Just registered on your site. Bought 68 Camaro SS L-78 28 years ago. Unbelievably received booklet with POP affixed, new car invoice, and other documentation today!!! VIN on dash and POP match. All options exist that are on POP. T0524MQ is stamped on engine pad and POP. However, VIN on engine pad is 730 later than car VIN. Two previous owners did NOT change block. Have talked to both. I am third owner. Those VINs would have been produced possibly the same day. Mistake at factory? What explanation could there be? It would seem the wrong engine was sent to assembly line. I've grappled with this for years, always wondering what was stamped on POP. Now I know. Your thoughts? If you need e-mail, it is glovell1@roadrunner.com. Any help would be much appreciated.
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.072 seconds with 19 queries.