Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - wisemanz28

Pages: 1 2 [3] 4 5 ... 16
31
General Discussion / Re: 69 camaro brakes
« on: July 28, 2019, 02:07:20 PM »

I suspect the brake booster is the problem, who would you guys suggest I send it to for a rebuild ?

32
General Discussion / Re: 69 camaro brakes
« on: July 25, 2019, 02:04:38 AM »
I started the car up today and at idle I revved it up and when I gained rpm,s the brake pedal depressed down , when I let it go back to idle the pedal raised up and got very hard again. Checked the vacuum hose and check valve and they looked good . Any way to check the brake booster?

33
General Discussion / 69 camaro brakes
« on: July 23, 2019, 08:41:35 PM »
Lately I noticed my brake pedal is really hard when using the brakes, also sometimes I here a groaning noise when pushing on the pedal. The car stalled a few times when stopping. I haven't checked anything out yet but wanted to get some tips on what I should be looking for. 

34
General Discussion / 1 man brake bleeder
« on: June 25, 2019, 12:30:59 AM »
I'm going to bleed the brakes in my 69 Camaro this weekend and I'm shopping brake bleeder kits. I'm looking for recommendations on a kit. I had a MityVac but it didnt last . I want something better.

35
General Discussion / Re: Suspension woes
« on: July 03, 2018, 09:53:46 PM »
Thanks again Scott

36
General Discussion / Re: Suspension woes
« on: July 01, 2018, 08:47:29 PM »
Agreed

37
General Discussion / Re: Suspension woes
« on: July 01, 2018, 04:11:55 AM »
That would be great, my car is a driver and I'm looking for condition.

38
General Discussion / Suspension woes
« on: June 30, 2018, 10:02:47 PM »
I just realized my upper control arm retainer washer and bolt are missing , darn thing just came loose and fell out. Any of the members know where I can locate an original bolt and washer? It's for a 69 Camaro.

39
General Discussion / team camaro
« on: February 10, 2018, 05:53:28 PM »
Forgot my password over at the Team Camaro site and can't figure out how to reteive it . Does anyone know how to get in touch with the administrator of this site directly ?

40
General Discussion / spark plugs
« on: September 26, 2016, 01:38:26 AM »
I would like to put a fresh set of spark plugs in my 1969 Z28, it has the original 302 in it , what would you guys recommend using? I drive the car around on weekends and don't really need a set of n.o.s. plugs in it.

41
General Discussion / Re: 1969 Muncie M21
« on: August 20, 2016, 07:40:11 PM »
Thanks for all the advise. I did change the fluid with Sta Lube and while I was under there I noticed my 1st/2nd gear shifting rod backing nuts were very loose, which was causing the 2nd gear to hang up. Readjusted and tightened everything and now it shifts like a dream.

42
General Discussion / Re: 1969 Muncie M21
« on: August 04, 2016, 11:40:36 PM »
I also thought it was a shifter issue or even a clutch issue, so I swapped my rebuilt trans out for another Muncie that I knew had no problems with it at all. The car shifted smoothly (upshifts and downshifts)

43
General Discussion / 1969 Muncie M21
« on: August 02, 2016, 11:37:26 PM »
What fluid would you guys recommend to use in my Muncie M21 Transmission ? I've had the trans rebuilt (twice) and after both rebuilds I am having the same shifting issues ( upshifting from 2nd to 3rd ). I'm thinking I might have the wrong fluid in it which is casing the hard shifting problems.

44
General Discussion / Re: CV fan clutch
« on: March 05, 2015, 10:16:26 PM »
I saw one a few years back sell for $695 shipped on Yenko.net. It was all original, not restored.

45
General Discussion / CV fan clutch
« on: March 04, 2015, 11:43:01 PM »
I'm just being curious but I wanted to know what a 1969 Z28 Camaro CV fan clutch sells for ?

Pages: 1 2 [3] 4 5 ... 16
anything