CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
November 21, 2014, 03:31:47 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
106445 Posts in 12409 Topics by 4785 Members
Latest Member: Bolaro 67 SS350
* Home Help Search Login Register
  Show Posts
Pages: [1]
1  Camaro Research Group Discussion / Maintenance / 427 Camshaft valve adjustment questions on: January 26, 2010, 03:54:27 PM
I picked up a lightly used (150miles) 427 that was in a 69 yenko clone. It has a solid lifter cam and the top end is noisy. Through the guy i got the motor from, I was able to get from the engine builder only that it was the correct cam for a yenko 427, but he doesn't remember which cam. Is there a safe backlash setting i can use on the valves without knowing which exact cam i have. The motor was set up to run on pump gas 10:1 comp. It seems that .024 or .025 is common backlash. Any thoughts?
2  Camaro Research Group Discussion / Maintenance / Heater wiring on: February 17, 2009, 09:37:37 AM
I am putting an EZ-Wiring kit in my 67.  Trying to find out the wiring code for the Heater Switch, box, and motor.  I want to use the original pigtails, but don't know what each wire is.  Does anyone have a diagram of this or know what the wires are.  No A/C.  There is an orange wire runing to the motor on the firewall.  I know this can't be too complicated.  Any help?  Thanks. Undecided
3  Camaro Research Group Discussion / Maintenance / Re: Stupid ??? How do you change the oil in a Muncie? on: February 09, 2009, 08:55:55 AM
Thanks for all the good info.  I will change the oil yearly.
4  Camaro Research Group Discussion / Maintenance / Re: Stupid ??? How do you change the oil in a Muncie? on: February 05, 2009, 01:42:22 PM
Thanks.  It probably doesn't need changed.  I will check the level and see what the oil looks like.
5  Camaro Research Group Discussion / Maintenance / Stupid ??? How do you change the oil in a Muncie? on: February 05, 2009, 11:47:33 AM
There is no drain plug.  I feel stupid to ask this ?, but I have never had one of these.  There must be a way without pulling it out and tipping it upside down.
6  Camaro Research Group Discussion / Maintenance / Re: Speedo goes tick tick tick faster as you go on: February 01, 2009, 02:01:23 PM
Thanks for the help.  I'll try that.
7  Camaro Research Group Discussion / Maintenance / Re: Speedo goes tick tick tick faster as you go on: February 01, 2009, 01:47:03 PM
it's a little bouncy. maybe 3-5 mph
8  Camaro Research Group Discussion / Maintenance / Speedo goes tick tick tick faster as you go on: February 01, 2009, 01:09:47 PM
 Bought a 67 camaro with a muncie.  While doing a preflight under the car, i noticed the speedo cable was disconnected.  Hooked it back up,  took a drive and the speedo goes tick tick tick faster as you go.  Is there a fix or a replace?
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.124 seconds with 19 queries.