CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
September 19, 2014, 10:58:26 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
104576 Posts in 12238 Topics by 4719 Members
Latest Member: Baconcks
* Home Help Search Login Register
  Show Posts
Pages: [1]
1  Camaro Research Group Discussion / Maintenance / Tachometer on: December 18, 2009, 11:30:17 PM
My factory in-dash tachometer reads 200 rpm higher at idle and almost 400rpm higher at freeway speeds. Since you guys have helped solve all my other problems,I thought I would throw this one your way. By the way, I have a GM HEI distributor. a friend told me this may be the problem and I need to install a "electronic signal filter" ??
2  Camaro Research Group Discussion / Maintenance / Re: Clutch shudder on: November 03, 2009, 06:54:09 PM
John, first gear shudders, in reverse in shudders all through the driveline all the way to the rearend. So far it's 2 votes for the
flywheel. Thanks again to both of you for your input.
3  Camaro Research Group Discussion / Maintenance / Re: Clutch shudder on: November 03, 2009, 04:55:52 PM
John, the flywheel I replaced didn't have the swirl marks in it as your picture shows. After installing the first clutch and expieriencing the shudder, I had second thoughts about putting a $50.00 re-surfaced fly wheel in the first place. I talked to a local clutch shop today and told me that bellhousing alignment is critical and often overlooked. He also said that if I started getting the shudder after the first install and everything else has been changed twice except the flywheel, that that may be the problem? He mentioned something about heat warping that wouldn't be visable to the eye? By the way I had no shudder in my driveline before changing the first clutch. Thanks for your response.
4  Camaro Research Group Discussion / Maintenance / Clutch shudder on: November 02, 2009, 11:29:24 PM
I recently replaced my old clutch with a Luk oem replacement, I also installed a re-conditioned flywheel,TO bearing etc. I took the car for a ride and experienced heavy clutch shudder in 1st and reverse. I didn't want to do the job 2nd time in the driveway (hard on the body) so I took it to a local shop, he replaced everything I did with another Luk set except the fly wheel since it only had 50 miles on it. Picked-up the car and it still has clutch shudder and the pedal is stiffer than usual ? I'm scheduled to take it back on Monday,any ideas or sugesstions? Thanks
5  Camaro Research Group Discussion / Restoration / Re: 1967 Horns on: June 10, 2008, 08:57:30 PM
Thanks Cheesy
6  Camaro Research Group Discussion / Restoration / 1967 Horns on: June 09, 2008, 10:55:25 PM
Does a 1967rs use low or high note horns? Or one of each?
7  Camaro Research Group Discussion / Restoration / 1967 front spoiler braces on: April 16, 2008, 10:37:35 PM
Has anyone had any issues with the fitment of the front spoiler braces? I just purchased a new front spoiler with the 2 braces that are supposed to mount from the lower part of the spoiler to the lower part of the front fender just in front of the tire. the braces are too short by  1/2 to 5/8 of an inch. Am I mounting it wrong or do I have the wrong braces? I purchased it from Classic industries and the kit says it comes with the correct braces (8 1/2 inches). Any advice is appreciatted.
8  Camaro Research Group Discussion / Restoration / 14 x 6 polished stainless trim rings on: March 09, 2008, 09:49:42 PM
Can anyone tell me where to get a good quality (made in the USA) set of 14x6 rally wheel trim rings? Just got a set from "American Restoration Products"  they are made in China and look like it. I really don't want to spend $250.00 for the GM OEM ones since my car is a nice quality weekend driver and not a numbers matching show car.THANKS
9  Camaro Research Group Discussion / Restoration / Re: 1967 Rear Package Tray on: January 03, 2008, 11:02:44 PM
Thanks for the info, it worked just as described
10  Camaro Research Group Discussion / Restoration / 1967 Rear Package Tray on: January 01, 2008, 10:21:43 PM
For the last year I have been restoring a 1967 rs. I have finally gotten around to installing a stereo and need info on replacing the rear package tray to install new speakers. I have purchased a new tray from Classic Industries but for the life of me can't figure out how to remove the old one? How do I remove back of the seat? I thought that the seat back would just lift out, but it won't budge?? Any suggestions are greatly appreciated. THANKS
11  Camaro Research Group Discussion / Maintenance / 1967 rear leaf springs on: May 27, 2007, 06:56:38 PM
I have a 67 rs with what appears to be stock 14x6 or 7 camaro rally wheels and 205x70 tires.The car has a mono leaf suspension with traction bars.I noticed that after installing the traction bars the rear of the car sits higher (too much space between the top of the tire and the fender well) If I switch to multi-leaf springs will this lower the car? I put the traction bars on due to severe wheel hop. Classic Industries sells as set of mult-leaf springs that will lower the car by 1 1/2 inches? Basically I would like the rear of the car to sit level with the front keeping the 14 inch wheels. I'm open to any suggestions,Thanks
12  Camaro Research Group Discussion / Maintenance / 1967 console seat belt clips on: November 01, 2006, 09:38:19 PM
Does anyone have a picture of were the seat belt clips are mounted on a 67 rs center console. I just bought a pair but can't find any mounting holes.
13  Camaro Research Group Discussion / Originality / 1967 camaro glovebox emblem on: October 23, 2006, 09:41:09 PM
I recently purchased a 67 rally sport and noticed 2 small square holes in the lower right corner of the glovebox door.I looked in my
Classic industries catalog and it only shows an emblem for a 1968 door? Does a 67 have an emblem also? or do I assume I have a 68 glovebox door?
14  Camaro Research Group Discussion / Maintenance / 1967 headlights on: September 24, 2006, 08:56:29 AM
What's Up? I have 25 reveiws of my headlight problem,but only one reply? Please help! Headlight motor won't shut off? THANKS
15  Camaro Research Group Discussion / Maintenance / 1967 headlight motor noise on: September 21, 2006, 11:10:44 PM
I just purchased a 67 RS with electric hide-way headlights.The doors open and the lights work but there is a constant loud whining noise even when the doors are fullly opened? is this normal? If not how do I go about fixing them.Thanks
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.092 seconds with 18 queries.