CRG Discussion Forum
Welcome, Guest. Please login or register.
Did you miss your activation email?
September 23, 2014, 11:23:45 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the CRG Discussion Forum!
Forum registration problems: Make sure you enter your email correctly and you check your spam box first. *Then* email KurtS2@gmail for help.
104713 Posts in 12247 Topics by 4719 Members
Latest Member: Baconcks
* Home Help Search Login Register
  Show Posts
Pages: [1]
1  Camaro Research Group Discussion / Mild Modifications / Re: 396 clearence problem on: July 28, 2006, 04:17:35 PM
thanks ill make shure to check that area! I didnt think about that
2  Camaro Research Group Discussion / Mild Modifications / Re: 396 clearence problem on: July 09, 2006, 03:58:56 PM
thats great! The measurements should help me out alot at least I will know for shure if I have the right frame mounts and im ordering new rubber mounts just to eliminate one more thing. I also have a different intake manifold im gonna try that sits alot lower then I think if I get shorter valve covers with the angled back, electric fan that should almost get my problems fixed what do ya think?
3  Camaro Research Group Discussion / Mild Modifications / Re: 396 clearence problem on: June 11, 2006, 12:54:02 PM
I forgot to mention that I do have the offset bb fan shroud but the fan sits about a 1/4" to tall and about the same to the driver side. Can you tell by the pix if the upper engine mounts could be the prob?
4  Camaro Research Group Discussion / Mild Modifications / Re: 396 clearence problem on: June 10, 2006, 10:05:27 PM
<img src="[url]http://img10.picsplace.to/11/thumbs/engine_comp_009.jpg" alt="Image Hosting by PicsPlace.to" >[/url]<img src="[url]http://img10.picsplace.to/11/thumbs/engine_comp_010.jpg" alt="Image Hosting by PicsPlace.to" >[/url]<img src="[url]http://img10.picsplace.to/11/thumbs/newest_032.jpg" alt="Image Hosting by PicsPlace.to" >[/url]<img src="[url]http://img10.picsplace.to/11/thumbs/newest_040.jpg" alt="Image Hosting by PicsPlace.to" >[/url]<img src="[url]http://img8.picsplace.to/img8/16/thumbs/engine_comp_011.jpg" alt="Image Hosting by PicsPlace.to" >[/url]<img src="[url]http://img8.picsplace.to/img8/16/thumbs/newest_015.jpg" alt="Image Hosting by PicsPlace.to" >[/url]
5  Camaro Research Group Discussion / Mild Modifications / 396 clearence problem on: June 10, 2006, 06:35:44 PM
I have a 67 Camaro with a non-factory 396 it did come with a small block though. Im having clearence problems with the ss hood, wiper moter (which some shorter valve covers might fix?), fan not lining up in the fan shroud and i think the distributer will fit but barely! I have the correct bottom engine mounts the top engine mounts are small block but I was told theres no hight difference! I will attach pix and if any one can help that would be great and if you would like me to snap some pix of a more specific area Ill do that! Thanks
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.086 seconds with 19 queries.