Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - 67 RS Ragtop

Pages: [1] 2 3 ... 6
1
General Discussion / Re: Members from old forum version please post here
« on: September 17, 2017, 08:21:09 PM »
67 RS Ragtop in old and new forum

2
Maintenance / Re: Vapor lock?
« on: June 28, 2017, 07:52:53 PM »
I have found that often the exhaust holes for the crossover slot are somewhat eaten up by the exhaust and not round, so the plugs do not perform a true seal. This is why I use a tap with grease on it (when working on an assembled engine) to keep most of the filings from entering the intakes exhaust ports. I simply tap and install a pipe plug, then reinstall the carb with the afore mentioned correct gaskets. Others have also welded them shut, or blocked off the ports at the intake gaskets (when the intake was off or removed). It's your car, hence, your choice. JM2C Timing is yet another possible contributing heat factor.

3
Maintenance / Re: Vapor lock?
« on: June 26, 2017, 03:44:39 PM »
JMO make sure your exhausts heat riser valve is not stuck in the closed position, and it opens fully when at operating temps (if you are still running one). One other issue that was supposedly recalled many years ago due to fire issues, was blocking off the exhaust passages at the intake below the carb. - simply remove carb., tap the ports and install pipe plugs, reinstall carb., etc..

4
Maintenance / Re: I broke it ! Don't think it's the clutch.
« on: May 30, 2017, 06:54:43 PM »
Often times the failed lining merely "stacks up" between the pressure plate and flywheel. This allows you to feel the pressure plate trying to release, but the clutch does not disengage - then you need to shut it down, shift into the desired gear, restart and limp home. I have seen this type of failure multiple times, and it may be what you experienced. FWIW

5
Maintenance / Re: 69 RF brake lock up?
« on: December 18, 2016, 03:14:11 AM »
Just wondering (maybe I missed it) what was the hydraulic pressures at both front calipers, while under light application? In my past life I used a set of gauges and actually verified pressures right to left, or front to back, etc., on problem vehicles (formerly a Factory rep for a truck manufacturer). This may be be a way to confirm the "cause" of your ongoing issue.

6
Forgot to mention you should have the air cleaner #6424487, per K19 A10, pg 258

7
 I believe that is the incorrect tube assembly. If you look closely at K19 A10, pg 258 it states via a note that the AIR valve assembly is installed the same as a 327 2bbl (found at K19 A9, pg257). This indicates the tube assy you need is item #15, part #3888364 (note the band for attaching the valve to the tube assy). I believe you will find that K24 A2, pg 267 is  for non A.I.R. (smog equipped engines), and it shows one bung at the fill tube, with the hose routings for both the 4bbl and 2bbl carbs (the picture is confusing, but is showing the location of the bung when the fill tube is installed for the two applications). If I'm wrong, I am sure others will correct me, but that is my opinion on your questions - hope it helps.

8
Originality / Re: Big Block 69 original cable routing
« on: May 25, 2016, 09:57:22 PM »
PM sent.

9
Originality / Re: Radio Delete Block-off Plug
« on: October 27, 2014, 03:57:57 PM »
My 10B '67 plug has a number (again somewhat weathered) and the number appears to be 4 (8 or 9)358 (9 or 4)3. Did not want to remove it, as it appears to be the original, as the car had the factory rear antenna. I can supply a picture if you need it, when I return after the 8th of Nov.

10
General Discussion / Re: Detail Help
« on: October 21, 2014, 04:41:36 PM »
The wire that supplies current goes through a circuit breaker that is mounted on the firewall (under the hood, above the steering column). Refer to your AIM, upc C06 sheet A1, on page 142. If you don't have an AIM, there's a free download at the General discussion Forum - hope this helps. That page also shows the switch that you inquired about. If you need further info or pictures you can PM me, and I will try to help.

11
Restoration / Re: Horn Button Assembly 67 Camaro
« on: April 12, 2014, 12:56:31 AM »
X2  There is a small plastic ring that insultes the spring plate from the wheel's center hub - it looks like yours is missing in action. The part is hard to see in the link sent, but look closely and you will see it around the metal spring plate. Hope this helps.

12
Restoration / Re: Horn Button Assembly 67 Camaro
« on: April 11, 2014, 01:35:10 AM »
Check your AIM, UPC 12, C2, Pg 176 for the standard wheel. Sorry I can't help more, but I have a RS with the shroud type wheel. If you don't have an AIM, there's a free download under the General discussions forum.

13
General Discussion / Re: Where to find a black oil fill tube
« on: February 09, 2014, 06:25:29 PM »
My early production '67 (L30) has no step in the tube  (other than the portion that goes into the intake manifold), and no tab for the return spring. Sorry I am not near the vehicle for pics. Hope this helps.

14
Restoration / Re: new restoration endevour
« on: November 27, 2013, 11:21:07 PM »
Looks like Evap-o-rust to me.

15
Restoration / Re: 68 Convertible Spare Tire Bracket
« on: November 27, 2013, 11:16:58 PM »
  I have a 67 convert, with the full size spare tire (14"), and will measure the location via the hole in the original factory trunk mat, if no one chimes in, as I have provided pics of the mat / hole to other members, and I believe the location is the same for 67 / 68, as long as it's the full size spare, and a convertible. PM me if you need pics or measurements. I replaced the complete trunk pan in my car and currently don't have the "J" hook mount plate installed.

Pages: [1] 2 3 ... 6