Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - 67 RS Ragtop

Pages: [1] 2 3 ... 7
1
Maintenance / Re: 69 RF brake lock up?
« on: July 20, 2018, 06:12:04 PM »
Not laughing, as I am older than that, just don't know how I got here.

2
Maintenance / Re: 69 RF brake lock up?
« on: July 19, 2018, 06:12:34 PM »
Glad to hear your issue has been corrected, as Safety is always first and foremost. I did wonder if you ever verified the application pressures at both front wheels (I didn't see mention of the pressures). If I had known they were the same i would have suggested having both rotors re machined and the pads burnished in to see if any changes were made. At any rate, glad your problem has been solved.

3
Restoration / Re: 1967 defrost duct mounting picture needed
« on: May 15, 2018, 10:45:31 PM »
PM sent.

4
Restoration / Re: 1967 defrost duct mounting picture needed
« on: May 15, 2018, 07:44:59 PM »
The two upper screws actually go through the backside of the cowl panel, just below the defroster outlets in the dash, while the lower attachment area is fastened through the firewall insulation mat, going through the actual cowl with the screw - hope this helps. BTW this must be installed prior to just about anything else under the dash, with the exception of the insulation mat. Forgot to mention, my original mat has a cutout in it for the bottom screw / mounting bracket of the duct assy.(I don't see this hole on a repo mat). My car has standard heater - no AC. PM me if you need pics of the actual parts, etc. my email is in my profile.

5
Restoration / Re: 1967 defrost duct mounting picture needed
« on: May 15, 2018, 07:24:03 PM »
As per the AIM, UPC1, sheet A7, page 30, the duct fastens to the dash (view A), but I will check on my 67 as it's apart, and get back to you. Sorry, couldn't find any pics, but will look at the actual parts, screws, etc.

6
General Discussion / Re: Members from old forum version please post here
« on: September 17, 2017, 08:21:09 PM »
67 RS Ragtop in old and new forum

7
Maintenance / Re: Vapor lock?
« on: June 28, 2017, 07:52:53 PM »
I have found that often the exhaust holes for the crossover slot are somewhat eaten up by the exhaust and not round, so the plugs do not perform a true seal. This is why I use a tap with grease on it (when working on an assembled engine) to keep most of the filings from entering the intakes exhaust ports. I simply tap and install a pipe plug, then reinstall the carb with the afore mentioned correct gaskets. Others have also welded them shut, or blocked off the ports at the intake gaskets (when the intake was off or removed). It's your car, hence, your choice. JM2C Timing is yet another possible contributing heat factor.

8
Maintenance / Re: Vapor lock?
« on: June 26, 2017, 03:44:39 PM »
JMO make sure your exhausts heat riser valve is not stuck in the closed position, and it opens fully when at operating temps (if you are still running one). One other issue that was supposedly recalled many years ago due to fire issues, was blocking off the exhaust passages at the intake below the carb. - simply remove carb., tap the ports and install pipe plugs, reinstall carb., etc..

9
Maintenance / Re: I broke it ! Don't think it's the clutch.
« on: May 30, 2017, 06:54:43 PM »
Often times the failed lining merely "stacks up" between the pressure plate and flywheel. This allows you to feel the pressure plate trying to release, but the clutch does not disengage - then you need to shut it down, shift into the desired gear, restart and limp home. I have seen this type of failure multiple times, and it may be what you experienced. FWIW

10
Maintenance / Re: 69 RF brake lock up?
« on: December 18, 2016, 03:14:11 AM »
Just wondering (maybe I missed it) what was the hydraulic pressures at both front calipers, while under light application? In my past life I used a set of gauges and actually verified pressures right to left, or front to back, etc., on problem vehicles (formerly a Factory rep for a truck manufacturer). This may be be a way to confirm the "cause" of your ongoing issue.

11
Forgot to mention you should have the air cleaner #6424487, per K19 A10, pg 258

12
 I believe that is the incorrect tube assembly. If you look closely at K19 A10, pg 258 it states via a note that the AIR valve assembly is installed the same as a 327 2bbl (found at K19 A9, pg257). This indicates the tube assy you need is item #15, part #3888364 (note the band for attaching the valve to the tube assy). I believe you will find that K24 A2, pg 267 is  for non A.I.R. (smog equipped engines), and it shows one bung at the fill tube, with the hose routings for both the 4bbl and 2bbl carbs (the picture is confusing, but is showing the location of the bung when the fill tube is installed for the two applications). If I'm wrong, I am sure others will correct me, but that is my opinion on your questions - hope it helps.

13
Originality / Re: Big Block 69 original cable routing
« on: May 25, 2016, 09:57:22 PM »
PM sent.

14
Originality / Re: Radio Delete Block-off Plug
« on: October 27, 2014, 03:57:57 PM »
My 10B '67 plug has a number (again somewhat weathered) and the number appears to be 4 (8 or 9)358 (9 or 4)3. Did not want to remove it, as it appears to be the original, as the car had the factory rear antenna. I can supply a picture if you need it, when I return after the 8th of Nov.

15
General Discussion / Re: Detail Help
« on: October 21, 2014, 04:41:36 PM »
The wire that supplies current goes through a circuit breaker that is mounted on the firewall (under the hood, above the steering column). Refer to your AIM, upc C06 sheet A1, on page 142. If you don't have an AIM, there's a free download at the General discussion Forum - hope this helps. That page also shows the switch that you inquired about. If you need further info or pictures you can PM me, and I will try to help.

Pages: [1] 2 3 ... 7