Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - mike willett

Pages: [1]
1
Restoration / 67 rs pinstripe- z21?
« on: July 31, 2017, 09:43:05 PM »
I am putting the pinstripe back on my 67 rs. i have the assembly instruction page for the z21 option.   i see that the stripe is 1/16/ space 1/8 and then 3/32.  i see the positioning of the the stripe down from the body lines for the 3 sections. i see the end detail.  I don't see the distance to the front end of the fender if i don't have the nose stripe. and the distance to the back of the quarter- mine says 126.625 which i can't make an sense of.  i am looking for those two dimensions. also the page says drawn on 8-24-66 and on the right side it has the revision record dated 9/8/66. my car was produced on 11/29/66.  is there a revised drawing?

2
General Discussion / new member 67 rs
« on: May 31, 2017, 03:18:52 AM »
i bought this sometime in the 1980's.  I have repainted it twice. this is the original color. car came from California 3 years before i bought it. I got the info on the original dealer and it was delivered to Hollywood ! That is all i know about the first owners. it has a 327 with a powerglide  trans. center console,factory air, vinyl top, tinted glass, power steering, power brakes,custom interior, deluxe belts,  front disc brakes were added a few years ago.

3
Restoration / 67 temp gauge
« on: May 31, 2017, 02:28:13 AM »
my temp gauge quit working last year.  i have gauges on the console. i have power at the back of the gauge.  the gauge goes to full bank if i  ground it at the back of the gauge- but does not move if i ground the wire on the sensor. seems like i need to check for continuity on that wire next- i suspect it is broken somewhere.  am i missing anything?

4
General Discussion / tachometer wiring 67
« on: May 20, 2017, 05:31:37 PM »
I have a 67 , it had a factory tach that had the guts removed before i got the car- so not sure if it had a factory tach or not.  i have a newer electronic dist with a tach output terminal that is not connected . I installed a new reproduction factory tach. it shows the rpm when cranking and drops to 0 as soon as it starts. the back of the tach is attached to the printed circuit only. Can i pick up the factory wiring and install it to that tach terminal?

5
General Discussion / 1967 camaro rs with 283?
« on: May 20, 2017, 04:02:50 PM »
i have owned a 1967 Camaro rs for about 30 years. spending a bit of time doing research that was not available when i got it. I am brand new to this site! My car was built in nov. of 1966 in van nuys. the motor that it came with is block stamped v0329go. a few sites that i have visited list that as a 283 with A.I.R for a full size/or camaro!  It doesn't seem like this engine is recognized as a Camaro motor. but yet when you read the history of the z28 which cam out in Dec. of 66 there is a memo that lists Piggins as driving a "high performance 283 camaro" The car is a factory air car with the pulleys for the air even when the air was removed. it also still had the high output alternator.  I know there is a lot of discussion about the 283 in Camaro's other than the few that were for export. does anyone have history of when the z28 was in " the works" ? are there any proven 283 in Camaro's other than exports? Any chance that this motor was the original? also what does that A.I.R. stand for?  Thanks

Pages: [1]